Smart-Home macht einfach Spaß


Installtion ioBroker auf dem Raspberry Pi

Amazon

ELV


Raspberry Pi 4 4GB**

Raspberry Pi 4 4GB**

Raspberry Pi 4 4GB**

Netzteil**

Netzteil**

Netzteil**

SD-Karte**

SD-Karte**

SD-Karte**

Aluminiumgehäuse**

Aluminiumgehäuse**

Aluminiumgehäuse**

Der ioBroker benötigt unteranderem die Software Node.js. Hierbei handelt es sich um eine Plattformunabhängige Java-Script Laufzeitumgebung. Hört sich etwas kompliziert an, ist es im Hintergrund garantiert auch, aber ein Smartphone ist im Hintergrund auch sehr kompliziert und wir können es trotzdem einfach nutzen.

Zu den einzelnen Versionen von Node.js gibt es allerdings noch interessante informationen. Bei den ungeraden Versionen zum Beispiel 9.x oder 11.x handelt es sich um Entwicklerversionen, deshalb sind diese eigentlich nicht für den Endanwender gedacht. Die geraden Versionen zum Beispiel 10.x oder 12.x sind Versionen welche den LTS-Status (Long Therm Status) erreicht haben und auch für den Endanwender geeignet sind. Bei diesen Versionen gibt einen gewissen Ablauf. Die ersten Monate wird die Version entwickelt anschließend erhält diese Version den LTS-Status. Jetzt biginnt von der Version für 18 Monate die aktive Phase und in den nachfolgenden 12 Monaten wird diese Version „nur noch“ gewartet. Es ist auch nicht immer Ratsam sofort auf die neueste Version (sobald der LTS-Status erreicht ist) zu aktualisieren. Es kann durchaus passieren, dass evtl. eine Software noch Probleme mit der aktuellen Version aufweist. Ist der IO Broker einmal installiert wird einem immer die empfohlene Version angezeigt. Ich bin da der Meinung: lieber eine Version älter als empfohlen, solange dieser Version noch gewartet wird. 

Den Status der einzelnen Versionen kann man auf der Internetseite von Node.js nachsehen.


1.Node.js prüfen

Ich gehe davon aus das aktuell noch kein Node.js installiert ist. Das kannst du überprüfen indem du nacheinander die folgenden drei befehle in die Shell eingibst:

Wenn in der Shell bash: nodejs Kommando nicht gefunden ausgegeben wird, ist keine Version installiert.


2.Node.js deinstallieren -OPTIONAL-

Sind die Versionen zu alt, kann mit den folgenden befehlen die Software deinstalliert werden. Vorher solltest du unbedingt ein Backup von deiner SD-Karte machen. 

Anschließend kannst du wie unter 1 beschrieben prüfen ob alles deinstalliert ist. 


3.Node.js installieren 

Um Node.js, Node und NPM zu installieren, fügst du mit dem ersten Befehl ein Repository hinzu. In diesem Fall wird die Version 12.x geladen. Anschließend werden die Pakte installiert und zum Schluss startest du den Raspberry Pi neu. 


5. Version prüfen 

Die Versionen kannst du wie unter eins beschrieben Prüfen 

6. ioBroker installieren 

 

Jetzt sollte der ioBroker installiert sein nachdem Du ich von der KonsoleSchell mit exit abgemeldet hast. kannst Du dich über der  IP vom Rasberry Pi mit dem Port 8081 mit dem ioBroker verbinden können. Ich habe in meinem Fall folgendes im Browser eingetragen:

192.168.0.215:8081

Wichtig ist natürlich das der PC mit dem Browser im selben Netzwerk angemeldet ist.


 

 










Ich hoffe Dir hat der Beitrag gefallen. Ich würde mich über ein like des Videos freuen, wenn du dann noch meinen Kanal abonnierst und die Glocke aktivierst verpass auch kein Video mehr.